Tuesday, 19.09.2017, 19:56
ACM Server
Welcome Guest | RSS
Main How-to-install - Forum Registration Login
[ New messages · Members · Forum rules · Search · RSS ]
Page 1 of 11
Forum » ACM Server » Discussion » How-to-install
How-to-install
Jedi_KnightDate: Sunday, 16.11.2008, 15:55 | Message # 1
Private
Group: Администраторы
Messages: 3
Reputation: 0
Status: Offline
See FAQ

May The Force be with you
 
KrakyDate: Wednesday, 19.08.2009, 20:06 | Message # 2
Private
Group: Пользователи
Messages: 3
Reputation: 0
Status: Offline
Hi,

I am trying to use your server, but i am meeting some problems.

Even though i am sure i put the Login and Password correct for uva online judge, when i try to select a problem through the server i get "SelectProblemHtml::RefreshProblems returned false." error.

Also, i tried to use SPOJ for a contest, but when i submit a problem it says "submission error". And if i open SPOJ webpage and check i see that the submission is AC with no problems.

Why am i getting this error?

Any help is appreciated.

Thx

edit: here is the log for Uva
19.08.2009 18:57:28.734 TID0000018C [Notice] UVa.log attached.
19.08.2009 19:10:24.875 TID000013FC [Error] Login: Wrong location:
19.08.2009 19:11:41.578 TID0000125C [Error] Login: Wrong location:
19.08.2009 19:12:29.390 TID000013FC [Error] Login: Wrong location: http://uva.onlinejudge.org/
19.08.2009 19:12:49.328 TID0000105C [Error] Login::Cut returned false.

Message edited by Kraky - Wednesday, 19.08.2009, 20:14
 
FlyDate: Wednesday, 19.08.2009, 20:24 | Message # 3
Admin
Group: Администраторы
Messages: 16
Reputation: 1
Status: Offline
Are you using the latest version?
 
KrakyDate: Wednesday, 19.08.2009, 20:32 | Message # 4
Private
Group: Пользователи
Messages: 3
Reputation: 0
Status: Offline
yes, i am. And i am not on a proxy.
 
FlyDate: Wednesday, 19.08.2009, 22:08 | Message # 5
Admin
Group: Администраторы
Messages: 16
Reputation: 1
Status: Offline
About UVa:
Try this new version: http://acm-server.ru/load/0-0-0-7-20

About SPOJ:
Please, post here an information about submission error from "spoj.log" file.

But still, the both plugins work on my computer.

 
KrakyDate: Wednesday, 19.08.2009, 22:34 | Message # 6
Private
Group: Пользователи
Messages: 3
Reputation: 0
Status: Offline
I guess it must be in my connection somehow? When i removed the Uva plugin and added the new one, it returned the same error, but after a long time (1 min or so). With the old plugin it took 5 seconds.
I also tried to change the port but to no effect. As this is not a problem in the server, what do you think might be causing it? I simply extracted the .exe to a folder and i put the .dll files with it then i ran the server and configured it from firefox.

I will try it from a different PC and get back to you.

SPOJ.log:
19.08.2009 22:11:59.937 TID000004E0 [Notice] SPOJ.log attached.
19.08.2009 22:26:43.156 TID00000D44 [Notice] GetLastSubmit: Last submit id = 0
19.08.2009 22:26:57.234 TID00000D44 [Error] SubSubmit: Too many loops.
19.08.2009 22:27:57.671 TID000008BC [Notice] SPOJ.log detached.

 
FlyDate: Wednesday, 19.08.2009, 22:48 | Message # 7
Admin
Group: Администраторы
Messages: 16
Reputation: 1
Status: Offline
Hm... May be your connection is too fast. UVa plugin takes about 5 minutes to start on my computer.

Please, send me the last 1 Mb of "ACMServer.log" to my email "fly3333@gmail.com". I will try to find an error. Don't forget to zip it.

 
FlyDate: Thursday, 20.08.2009, 22:54 | Message # 8
Admin
Group: Администраторы
Messages: 16
Reputation: 1
Status: Offline
The problem with SPOJ was that you had entered you login with capital letter. Sphere online judge requires lower case character only in login to work properly. But to prevent this problem again I have update SPOJ plugin as it doesn't require to enter your login in lower case. See SPOJ plugin page.
 
zhandos1Date: Thursday, 26.01.2012, 12:38 | Message # 9
Private
Group: Пользователи
Messages: 3
Reputation: 0
Status: Offline
Что делать если в логах написано:
TID0000000B [Error] cWardServer::Process: server_socket.Bind returns SOCKET_ERROR. WSAGetLastError returns 10013
 
FlyDate: Friday, 27.01.2012, 01:49 | Message # 10
Admin
Group: Администраторы
Messages: 16
Reputation: 1
Status: Offline
It means that the port you chose is using with another application. See FAQ to change the port.
 
Forum » ACM Server » Discussion » How-to-install
Page 1 of 11
Search:

Copyright Victor Vinogradov © 2008-2017 Free website builderuCoz